On Demand Practice Management Company Account Set Up

Welcome to Rethink Behavioral Health!  Below are the On Demand Practice Management Company Account Set Up Resources to help you get started in your account.  Follow the steps below to set up and customize your account for your Practice Management implementation.  Once you've watched the video and reviewed all resources, please schedule a time to meet with your Practice Management Implementation Specialist to review your account and complete a practice management implementation plan.

STEP 1 : WATCH VIDEO OF THE OVERVIEW OF PRACTICE MANAGEMENT COMPANY ACCOUNT SET UP AND REVIEW SELF-HELP TUTORIALS:

 

Training Category

Training Link

Description

Required Company Account Set Up Items

https://rethinkautism.atlassian.net/wiki/spaces/RBS/pages/51223798

 

 

Overview of all required company account set up items that users will need to complete in order to schedule

Basic Info, Locations, Service Lines and Services, Funders and Billing Codes, Staff Member Settings, Company Pay Codes, Scheduling Preferences. Roles and Permissions

Funders and Billing Codes

Adding Funders to the Company Account

Text version of Funder Set Up shows how to add funder billing codes

Referring Providers

https://rethinkautism.atlassian.net/wiki/spaces/RBS/pages/2855764020

Lean how to add referring providers.

Client Report Templates

 

Creating Billable and Non Billable Session Note Templates

Learn now to add billable and non billable session notes

Client Report Templates

Add Funders to Existing Client Report Templates

Learn how to add new Funders to an existing Client Report Template

Client Filing Cabinet: Session Notes

Overview of the Client File Cabinet

https://rethinkautism.atlassian.net/wiki/spaces/RBS/pages/2856779914

Learn about the File Cabinet permissions and How the Session Note Folder works.

Client Profile: Funder Assignments

Assign Funders/ Add Policy Info to Client Profile

Learn how to assign a Funder to a client

Client Profile: Diagnosis

Lean how to add a diagnosis to a client.

Client Profile: Authorizations

Authorizations

Videos- How to Copy Authorizations/Add Multiple Services 2:02

Learn how to Add/ Edit and add multiple services to an authorization at a time.

 

Staff Profile: Add Staff Member

Add A Staff Member for Scheduling

Learn how to add a new staff member

Staff Profile: Adding Staff Paycodes

Staff Pay Codes

Learn how to assign paycodes to staff

Staff Profile: Adding License/Certifications

Manage Staff Licenses and Credentials (Staff Profile)

Learn how to manage and track credentials

STEP 2: LOG IN, REVIEW & ADJUST COMPANY ACCOUNT SETTINGS

STEP 3:  COMPLETE STAFF MEMBERS SET UP FOR PRACTICE MANAGEMENT:

  • General Info (ensuring NPI & Medicaid ID are added if needed per your funder requirements)

  • Pay codes

  • License/Certifications

  • Assignments (optional, depending on roles/permissions)

  • Availability (optional)

STEP 4: COMPLETE CLIENT SET UP FOR PRACTICE MANAGEMENT

  • Demographics (with address)

  • Funder

  • Diagnosis

  • Referring Provider (if desired/needed)

  • Authorization

  • Availability (optional)

STEP 5: COMPLETE BILLABLE SESSION NOTE TEMPLATES (Nonbillable Session Notes are optional)

  • Ensure templates are attached to funders.

STEP 6: BEGIN SCHEDULING & COMPLETING APPOINTMENTS

CONTACT INFORMATION FOR SUPPORT:

Rethink Behavior Health Support

support@rethinkbh.com

646-257-2919 ext. 288